股票学习网

【通达信】乖离比主图指标公式

2019-09-01 11:21:45| 发布者: | 查看: 623| 评论: 0

摘要: 动态止损度:=5;

黑:=0;{下跌通道黑色K线开关}

离L:=0;{乖离提示开关}

提示:=0;{买卖文字提示开关}

布林M:=0;{开关}

MMA:=0;

五:MA(CLOSE,5),COLORWHITE;

十:MA(CL...

动态止损度:=5;
黑:=0;{下跌通道黑色K线开关}
离L:=0;{乖离提示开关}
提示:=0;{买卖文字提示开关}
布林M:=0;{开关}
MMA:=0;
五:MA(CLOSE,5),COLORWHITE;
十:MA(CLOSE,10),COLOR00FFFF;
M18:=MA(CLOSE,18),COLORRED;
离基:=五;
离O:=离基*1.20,COLOR555555;
离A:离基*1.15,COLOR555555;
离B:离基*1.10,COLOR555555;
离C:离基*0.90,COLOR555555;
离D:=离基*0.85,COLOR333333;
EXP50:=EXPMA(CLOSE,50),COLORGREEN;
MA30:MA(CLOSE,30),LINETHICK1,COLORRED;
MA60:MA(CLOSE,60),COLORGREEN;
β0:=(H-L)/2+L,LINETHICK0;
α:=β0,LINETHICK0;
β:=REF(β0,1),LINETHICK0,COLORGREEN;
γ:=REF(β0,2),LINETHICK0,COLORMAGENTA;
{涨:PLOYLINE(C>REF(C,1),CONST(C)),(www.efUcoO.coM)COLOR0000AA,LINETHICK1;
跌:PLOYLINE(C<>
高:PLOYLINE(1,CONST(HHV(H,50))),COLOR770077,LINETHICK1;
低:=PLOYLINE(1,CONST(LLV(L,50))),COLOR777700,LINETHICK1;
中:=PLOYLINE(1,(高-低)/2+低),COLOR005555,LINETHICK4;
止损价:=CONST(HHV(C,5)*(www.efuCoO.coM)(100-动态止损度)/100);
止:PLOYLINE(CONST(C)<>
DRAWTEXT(DYNAINFO(7)<=止损价 and="">
AA:=CLOSE/REF(C,1)>=1.09;
BA:=CLOSE/REF(C,1)>=1.09;
DRAWKLINE(H,O,L,C);
STICKLINE(AA,O,C,2.5,1),COLORYELLOW;
MA1:=MA(CLOSE,5),COLORRED;
MA2:=MA(CLOSE,10),COLORYELLOW;
MA3:=MA(CLOSE,20),COLOR770077;
E50:=EXPMA(CLOSE,50),LINETHICK1,POINTDOT,COLORLIGREEN;
E100:=EXPMA(CLOSE,100),POINTDOT,COLORGRAY;
MA181:MA(C,181),COLORGRAY;
{MA60:=MA(C,60),COLOR007700;}
{周:IF( MMA=1 ,MA2,DRAWNULL),COLORYELLOW,LINETHICK1;
月:IF( MMA=1 ,MA3,DRAWNULL),COLORWHITE,LINETHICK1;
季:IF( MMA=1 ,MA4,DRAWNULL),COLORGREEN,LINETHICK1;}
{IF(C>E50 ,E50,DRAWNULL),COLOR00FF00,LINETHICK1;}
IF(CONST(α>β) AND DYNAINFO(7)>0,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;
IF(CONST(α<=β)and dynainfo(7)="">0 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINETHICK1;
IF(CONST(α>β) AND DYNAINFO(7)>0 AND DYNAINFO(7)>=高*0.99,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;
IF(CONST(α<=β)and dynainfo(7)="">0 AND DYNAINFO(7)<=低*1.01>
N1:=12;
N2:=26;
N3:=9;
DIFF:=(EMA(CLOSE,N1) – EMA(CLOSE,N2));
DEA:=EMA(DIFF,N3);
MACD:=(2 * (DIFF – DEA));
MACD2:=MACD;
SARH:=CLOSE>SAR(4,2,20);
{IF(C
{IF(C
{IF(五>=REF(五,1) ,离A,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五>=REF(五,1) ,离B,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五<=ref(五,1)>
IF(五<=ref(五,1)>
五V:=MA(V,5);
{IF(五V>=REF(五V,1) ,离A,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五V>=REF(五V,1) ,离B,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五V<=ref(五v,1)>
IF(五V<=ref(五v,1)>
{IF(五
IF(五
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
STICKLINE(C
STICKLINE(MA1
STICKLINE(BA AND C<>
{DRAWICON(MACD>REF(MACD,1) AND CROSS(C,MA3) AND 提示=0 ,L,1);}
{DRAWICON(REF(C>MA3 AND 提示,1) AND CROSS(MA(C,5),C),H,2);}
N:=14;
M:=6;
TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/TR;
MDI:=DMM*100/TR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
DMIJX:=CROSS(PDI,MDI) AND C>O ;
{STICKLINE(DMIJX,H,L,0,1),COLORYELLOW;
STICKLINE(DMIJX,O,C,2.7,0),COLORYELLOW;}
{DRAWICON(DMIJX AND 提示=0,L,1);}
{DRAWTEXT(H>离A,离A/0.99,’★’),COLORYELLOW;}
头上边:=MAX(O,C),NODRAW;
头下边:=MIN(O,C),NODRAW;
垂头:=ABS(O-C),NODRAW;{垂头}
长针:=(头下边-L),NODRAW;{长针}
垂:=长针/垂头>2 AND (H-头上边)<=长针 and=""><>
DRAWTEXT(垂 AND L<=llv(l,3) and=""><离c and="" 提示,l/1.01,'针')="" and="">
DRAWTEXT(H>MA(CLOSE,5)*1.07 AND ISLASTBAR AND 提示,H*1.01,’离!’),COLORGREEN,LINETHICK2;
DRAWTEXT(LMA(CLOSE,5) AND 提示=0 AND H
{////MACD反身向上////}
{MACD红缩:=REF(MACD,1)>MACD AND MACD>0;
DRAWTEXT(REF(EVERY(MACD红缩,3),1)
AND MACD>REF(MACD,1) AND C>MA(C,22) AND 提示=0,L/1.02,’启动’),COLORWHITE;
}
{////MACD反身向上2////}
{MACD红缩2:=REF(MACD,1)>MACD AND MACD>0;
DRAWTEXT(REF(EVERY(MACD红缩2,2),1)
AND MACD>REF(MACD,1) AND C>MA(C,22) AND EVERY(DIFF>0,3) AND 提示=0,L/1.02,’起动’),COLORWHITE;
}
{突破买进(源码)}
{DRAWTEXT(DYNAINFO(7)>0 AND ISLASTBAR ,HIGH,'(“DYNAINFO(7)”)’);}
上5日:=REF(EVERY(C
STICKLINE(上5日,H,L,0,0),COLORFF00FF;
{STICKLINE(上5日,O,C,2.7,0),COLOR3366FF;}
STICKLINE(上5日,O,C,2.7,0),COLORFF00FF;
DRAWICON(上5日,L,1);
破5日:=REF(EVERY(C>MA1,4),1) AND CROSS(MA1,C);
DRAWICON(破5日,H,2);
DT:=REF(CLOSE/REF(C,1),1)<>
DRAWTEXT(AA AND DT AND CURRBARSCOUNT<60>
SC1:=MACD.MACD<>
SC2:=CROSS(十,五);
SC3:=MA(V,5)<>
SC:=SC1 AND SC2 AND SC3 ;
DRAWTEXT(SC AND CURRBARSCOUNT<10>
JC1:=MACD.MACD>0;
JC2:=CROSS(五,十);
JC3:=MA(V,5)>MA(V,10);
JC:=JC1 AND JC2 AND JC3 ;
DRAWTEXT(JC AND CURRBARSCOUNT<20>
{ZS:=CROSS(DMI.ADXR,DMI.ADX);
DRAWTEXT(ZS AND CURRBARSCOUNT<10>
{IF(五<>
{XQK:=H
DRAWTEXT(XQK AND CURRBARSCOUNT<20>
SQK:= L>REF(H,1);
DRAWTEXT(SQK AND CURRBARSCOUNT<20>
{www.gainiangu.com 概念股网_通达信股票指标公式}
DRAWTEXT(CROSS(H,离B) AND CURRBARSCOUNT<10>
DRAWTEXT(CROSS(H,离A) AND CURRBARSCOUNT<10>
DRAWTEXT(CROSS(离C,L) AND CURRBARSCOUNT<10>
DRAWTEXT((C<>
DRAWTEXT((C<2>

 

相关阅读

股票指标

第一指标公式网|炒股入门知识|9908006|178股票学习网

股票学习网提示:股票学习网站内资料未经授权禁止转载、摘编、复制或建立镜像,如有违反,追究法律责任。

股票学习网,炒股入门,第一指标公式网,股票入门基础知识,学习炒股,www.gpxx8.com 股票学习网 QQ

返回顶部